30 of my IOT devices just went offline.

  • 1
  • Problem
  • Updated 3 years ago
I just had 30 of my Neo Aeris sims go offline.  We use some Aeris (T-mobile here in Mississippi) and some AT&T.  Yesterday between 12:00 and 2:00 CST around 30 of our units went offline and they all have Aeris cards.  It appears to be all the Aeris cards in my account are offline. I can see no errors in my account such as billing.  

In case someone from Aeris sees this, an example is 89185014080500002174.  This one I have here that I am working with and it also will not make the internet connection like it usually does.  

I get the following: 

AT+CGDCONT=1,"IP","neo.iot.net"
OK


AT#SGACT=1,1

#SGACT: 10.136.255.156

OK


Sending: AT#SD=1,0,80, "www.XXXXXXXX.net"AT#SD=1,0,80, "www.XXXXXXXXX.net";

ERROR




I have no idea what the problem would be.  Of course since I'm not paying $1000/month for support,  I cannot call anyone at Aeris, so here I am.  In a bind with units scattered across several counties. 
Photo of Daniel Cole

Daniel Cole

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Vaibhav Mareddy

Vaibhav Mareddy, Official Rep

  • 24 Posts
  • 0 Reply Likes
Daneil,

Thanks for posting an issue you are facing. For the listed ICCID above we haven't seen any transaction from device to network from 27th to 30th, was it powered off? Currently device is active and sending data, can you please check the attached screenshot. Also, can you explain what exactly do you mean by offline? Do you see the device registered on to the network on your dashboard?

Thanks
Photo of Daniel Cole

Daniel Cole

  • 4 Posts
  • 0 Reply Likes
Hi,

Thank you for the reply.   The device that you posted the info for is my test unit.  I had it powered off for the last few days.    Please look at device: 89185014080500236749   .  This device is one of our many deployed in the field that stopped communicating with our server yesterday.  You can see the different in data transfer before and after 2:00 p.m. , yesterday, 7/30.  


My test device here get's an IP address just find, but when I try to make a connection with the SocketDial, as I always do, it fails.  It fails wether I try to connect to my server or to another.  Therefore I do not believe it's my server denying the connection. 

Thanks,

Daniel
Photo of Daniel Cole

Daniel Cole

  • 4 Posts
  • 0 Reply Likes
Here is an example of what I am receiving with my Aeris sim vs. my AT&T sim. 


Aeris:

Sending: AT+CREG?AT+CREG?

+CREG: 0,5

OK
Sending: AT+CGSN
AT+CGSN

351579054938517

OK

Sending: AT+CGDCONT=1,"IP","neo.iot.net"
AT+CGDCONT=1,"IP","neo.iot.net"

OK

Sending: AT#SGACT=1,1
AT#SGACT=1,1

#SGACT: 10.136.6.99

OK

Sending: AT#SD=1,0,80, "www.google.com";
AT#SD=1,0,80, "www.google.com";

ERROR


----------------------------------------------------------------------------------


AT&T: 

Sending: AT+CREG?AT+CREG?

+CREG: 0,1

OK
Sending: AT+CGSN
AT+CGSN

351579054938517

OK

Sending: AT+CGDCONT=1,"IP","wap.cingular"
AT+CGDCONT=1,"IP","wap.cingular"

OK

Sending: AT#SGACT=1,1
AT#SGACT=1,1

#SGACT: 10.188.127.234

OK

Sending: AT#SD=1,0,80, "www.google.com";
AT#SD=1,0,80, "www.google.com";

CONNECT
FOUND CONNECT
--Start Sending Post Data--
Sending: POST www.google.com HTTP/1.1
Sending: Host: www.google.com
Sending: Content-Type: application/x-www-form-urlencoded
Sending: Content-Length: 55
Sending: 
Sending: Connection: close
Sending: 
HTTP/1.1 405 Method Not Allowed
Allow: GET, HEAD
Date: Fri, 31 Jul 2015 21:37:32 GMT
Content-Type: text/html; charset=UTF-8
Server: gws
Content-Length: 1453
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Alternate-Protocol: 80:quic,p=0

<!DOCTYPE html>
<html lang=en>
  <meta charset=utf-8>
  <meta name=viewport content="initial-scale=1, minimum-scale=1, width=device-width">
  <title>Error 405 (Method Not Allowed)!!1</title>
  <style>
    *{margin:0;padding:0}html,code{font:15px/22px arial,sans-serif}html{background:#fff;color:#222;padding:15px}body{margin:7% auto 0;max-width:390px;min-height:180px;padding:30px 0 15px}* > body{background:url(//www.google.com/images/errors/robot.png) 100% 5px no-repeat;padding-right:205px}p{margin:11px 0 22px;overflow:hidden}ins{color:#777;text-decoration:none}a img{border:0}@media screen and (max-width:772px){body{background:none;margin-top:0;max-width:none;padding-right:0}}#logo{background:url(//www.google.com/images/errors/logo_sm_2.png) no-repeat}@media only screen and (min-resolution:192dpi){#logo{background:url(//www.google.com/images/errors/logo_sm_2_hr.png) no-repeat 0% 0%/100% 100%;-moz-border-image:url(//www.google.com/images/errors/logo_sm_2_hr.png) 0}}@media only screen and (-webkit-min-device-pixel-ratio:2){#logo{background:url(//www.google.com/images/errors/logo_sm_2_hr.png) no-repeat;-webkit-background-size:100% 100%}}#logo{display:inline-block;height:55px;width:150px}
  </style>
  <a href=//www.google.com/><span id=logo aria-label=Google></span></a>
  <p><b>405.</b> <ins>That’s an error.</ins>
  <p>The request method <code>POST</code> is inappropriate for the URL <code>/</code>.  <ins>That’s all we know.</ins>
HTTP/1.0 400 Bad Request
Content-Type: text/html; charset=UTF-8
Content-Length: 1419
Date: Fri, 31 Jul 2015 21:37:32 GMT
Server: GFE/2.0
Photo of Vaibhav Mareddy

Vaibhav Mareddy, Official Rep

  • 24 Posts
  • 0 Reply Likes
Daniel,

From what I understand looking at your logs, you were able to establish packet session but  application data was not transferred successfully to the server and device was not offline. Did you change anything on your server side or device software conifg? Can you provide details on type of modem you are using.
Photo of Daniel Cole

Daniel Cole

  • 4 Posts
  • 0 Reply Likes
Hi,

You guys must have done something because they all just came online and started logging again.  Thanks for whatever it was.  

Nothing changed on my server side, but in order to rule that out, I did the test of connecting to google's servers.  Google's servers would not even respond, and they responded fine if I put in an AT&T sim.   anyways, whatever the problem was, it must have been resolved now.  

Thanks for your help.