AT#SD Not Working

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Can ping any website, so DNS looks OK. AT#SD on a MultiTech MTSMC-H5 normally either times out or never returns a CONNECT; is there an example of using socket dial on Aeris that is available? Is there something obvious that I'm doing wrong? I believe ^J and ^M are being sent correctly - MultiTech support can achieve a socket dial with the -H5, but using a T-Mobile SIM ...

AT#SD=0,80,"www.telit.com",0,0


Never returns a CONNECT ...

Thanks!

Mike M.
Photo of Mike Moore

Mike Moore

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Mike,

Thanks for the post. Two questions just to check the boxes:

  1. Have you programmed the Neo APN in your radio module? Learn more
  2. Do you send any other command(s) prior to #SD?
Best,
Bob
Photo of Mike Moore

Mike Moore

  • 5 Posts
  • 0 Reply Likes
Bob:

1. Yes, the APN is programmed as pinging works OK
2. Here is an example terminal shot - note that the usual behavior is for AT#SD to hang and never respond with CONNECT. The MultiTech support seems to think eveything is being done correctly with ATing the modem. Signal strength is better today with a larger antenna - -97dBm rather than -107dBm below.

#MWI: 1,1,0
AT+CMEE=2
OK
AT+CPIN?
+CPIN: READY

OK
AT+CSQ
+CSQ: 3,2

OK
AT+CREG?
+CREG: 0,5

OK
AT+CGREG?
+CGREG: 0,5

OK
AT#SERVINFO
#SERVINFO: 437,-99,"T-Mobile","310260",219,AB7B,128,3,-107,"II",01

OK
AT#PSNT?
#PSNT: 0,3

OK
AT+GMM
HE910-D

OK
AT+GMR
12.00.023

OK
AT+CGDCONT=1,"IP","neo.iot.net"
OK
AT#SCFG=1,1,300,240,600,50
OK
AT#SCFGEXT=1,2,0,0,0,0
OK
AT#SGACT=1,1
#SGACT: 10.136.48.205

OK
AT#SD=1,0,80,"www.telit.com";


Any help greatly appreciated - thanks!

Mike M.
Photo of Mike Moore

Mike Moore

  • 5 Posts
  • 0 Reply Likes
Bob:

Somehow a semicolon appeared in the post after the AT#SD - not present in the log file, sorry ...

Thanks!

Mike M.
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Mike,

Looking at the command you provided:....

AT#SD=0,80,"www.telit.com",0,0

it appears you've omitted the connection type (<connMode>) parameter, which is the third parameter after IP address (following <closureType> and <IPort>).

Please review the excerpt below from the Telit AT Commands Reference Guide and let us know if you have additional questions.

Best,
Bob





Source:
Telit Wireless Solutions
HE910/UE910 AT Commands
Reference Guide
80378ST10091A Rev. 5 – 2013-07-01
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Mike,

We've done some additional testing in our lab and I'd like to amend my previous post. Here are the commands that work in our testing:

AT#SD=1,0,80,"www.telit.com"
AT#SD=1,0,80,"www.telit.com",0,0,0

The last three parameters are optional. The first three, <connId>, <txProt>, and <rPort> are required. Please try these and let us know.

Apologies for the confusion caused with the previous post.

Best,
Bob
Photo of Mike Moore

Mike Moore

  • 5 Posts
  • 0 Reply Likes
Bob:

Sure, the leading 1 is omitted in my first post - but it is there on the log, so sorry for the initial typo - will try again to be sure, but the actual command stream/stack is in the longest post, about 3 hours ago; as the immediately subsequent post says, when I cut and pasted from the log file a semicolon go in there somehow, and that line has the parameter linking the connId ...

Thanks!

Mike M.
Photo of Mike Moore

Mike Moore

  • 5 Posts
  • 0 Reply Likes
Bob:

Just got a CONNECT using AT#SKTD after AT&K0 - may mean something with a context is awry or that flow control was meddlesome ...

Here's the contexts/successful snippet:

OKAT&K0
OK
AT#GPRS=1
+CME ERROR: context already activated
AT+CGPADDR=1
+CGPADDR: 1,"10.136.54.110"

OK
AT+CGDCONT=?
+CGDCONT: (1-5),"IP",,,(0,1),(0,1)

OK
AT+CGDCONT?
+CGDCONT: 1,"IP","neo.iot.net","0.0.0.0",0,0
+CGDCONT: 2,"IP","neo.iot.net","0.0.0.0",0,0
+CGDCONT: 3,"IP","neo.iot.net","10.136.46.82",0,0

OK
AT#SKTD=0,80,"google.com"
CONNECT
HTTP/1.0 200 OK
Date: Thu, 08 Jan 2015 03:11:45 GMT
Expires: -1
Cache-Control: private, max-age=0
Content-Type: text/html; charset=ISO-8859-1
Set-Cookie: PREF=ID=db31f8607b499777:FF=0:TM=1420686705:LM=1420686705:S=CpGAcb8nkjq6TZdj; expires=Sat, 07-Jan-2017 03:11:45 GMT; path=/; domain=.google.com
Set-Cookie: NID=67=UaxgtHznNZD3b6tiFoIauRLzL0616EGHXrP2uPa5KBy5KsrU6q5qs7hAMQvltFdC7pYAe-a3pLaaitGTV_4gXJMUroA0m-h1noYyWSCyY4CroaLBbFPWgVoqHlymKVNR; expires=Fri, 10-Jul-2015 03:11:45 GMT; path=/; domain=.google.com; HttpOnly
P3P: CP="This is not a P3P policy! See http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=151657 for more info."
Server: gws
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Alternate-Protocol: 80:quic,p=0.02


Thanks!

Mike M.