Can't ping

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I'm using the MikroElektronika GSM Click board, which has a Telit GL865-quad module on it. To start I was simply trying to send commands from a terminal window.

at+gmi
Telit
OK
at+gmm
GL865-QUAD
OK
My SIM's ICCID is 89185014080500238612. The dashboard diagnostics are all green. If I follow along the getting started tutorial, I see something like this:

at+cgdcont?
+CGDCONT: 1,"IP","neo.iot.net","0.0.0.0",0,0
OK
at+creg?
+CREG: 0,5
OK
at#sgact=1,1
ERROR
That's not good. I tried the following:

at#sgact=1,0
OK
at#sgact=1,1
#SGACT: 10.136.22.43
OK
That seems promising. The IP address matches the dashboard. Now ping:
at#ping="www.aeris.net";
#MWI: 1,1,0
That's all I ever get. The dashboard shows some packet traffic, but mostly zero bytes transferred.

Any help would be appreciated. I've used the module with a T-Mobile SIM, and was able to make voice calls and send and receive text messages. I was not able to connect with data using the T-Mobile SIM, though.

I've tried ping and SMS from the dashboard, and both failed.
Photo of Scott M

Scott M

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Scott,

Thanks for the post. To ping from the AerPort dashboard you need to enable ICMP ping on the radio module, using the following AT command:

AT#ICMP=2


These screen shots show our results in the lab:






Increase the number of pings to 10 with a time out, as follows:


AT#PING =www.aeris.net,10,32,600,255 



This will send 10 ping requests to google.com with a length of 32, a maximum time out of 600 (in 100 ms units) and a time to live of 255. 



For SMS, I believe you need to change the mode of SMS from PDU to
text in the radio module and enable the message indication:


AT+CMGF=1

At+cnmi=1,1

AT+CMGL="ALL" 



Note that SMS to and from consumer handsets are not allowed.

Regards,
Bob
(Edited)
Photo of Scott M

Scott M

  • 3 Posts
  • 0 Reply Likes

Hi Bob,

Thanks for the speedy reply. It still doesn't work, or at least I haven't been able to do anything from the module using AT commands that makes me think I'm actually transferring data. 

Although, the SMS did go through, so that's some progress.

But I still can't ping from either direction. One thing that seems different from what my module does compared to your tutorial is that when I type AT#SGACT? it comes back with "1,1" which means that the context is already activated. I can't type AT#SGACT=1,1 without getting an ERROR response. The only way I seem to be able to activate a context is to first enter AT#SGACT=1,0 to deactivate the context, then enter AT#SGACT=1,1 to activate. Then the module comes back with an IP address, but if I try to ping from the module to google.com (or aeris.net) I never see a response.

No doubt I'm doing something silly, since I have no experience with the AT command set. Is there any additional help you can offer?

Thanks,

Scott

Photo of Scott M

Scott M

  • 3 Posts
  • 0 Reply Likes
Update. I think it was my own silliness. I was fixated on the software side, but I checked the dc supply and I believe that it wasn't stiff enough for the module. I've switched supplies and now I can magically ping from the module.

Thanks again for your help! I am still curious about the AT#SGACT question.

Scott