Device not registering on the network

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I have a tracking device that I want to test on the Aeris Network.  I installed one of the Neo Sim cards that was provisioned and set up to bill.  The device never registered on the network and I could not communicate with it.  The sim was installed correctly.  I removed the sim and replaced it with one from SimpleMobile and the device became active, so I know the device is good.
Photo of Tony Valentino

Tony Valentino

  • 14 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Tony,

Thanks for the post. Our logs show registration at 17:27 GMT today for the ICCID ending in 8315. You should see that in the transaction history log on your Devices tab. Is that the SIM you're referring to?

Regards,
Bob
Photo of Tony Valentino

Tony Valentino

  • 14 Posts
  • 0 Reply Likes
Yes that is the sim.  However the device panel says it is not registered, and when I try to ping the device, I get no response
Photo of Tony Valentino

Tony Valentino

  • 14 Posts
  • 0 Reply Likes
The sim now shows registered, but I still can't ping and the device shows no gsm activity.
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Tony,

What process are you using to start a packet data session prior to the ping? It would be helpful if you could share that.

Regards,
Bob
Photo of Tony Valentino

Tony Valentino

  • 14 Posts
  • 0 Reply Likes
I was in the diagnostic panel and clicked the ping device button.  That's it.  I've also tried to sms the device from the diagnostic panel but keep getting ErrorCode 6.  Also, while the device appears registered, there doesn't appear to be any GSM activity - the device itself blinks when the GSM link is established and it is not doing that.
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Tony,

It sounds like your issue is that you don't have the Neo APN configured in your device. Please refer here for instructions.

Regards,
Bob
Photo of Tony Valentino

Tony Valentino

  • 14 Posts
  • 0 Reply Likes
That's what I am actually trying to do.  The way this device works is that the apn is set via sms.  Since this is an off the shelf consumer device, it does not have a way to configure the apn via a terminal interface - only via sms.  I tried to send the configuration command via sms in the diagnostic panel but keep getting error code 6.  I am trying another device with another sim now.  
Photo of Tony Valentino

Tony Valentino

  • 14 Posts
  • 0 Reply Likes
Bob, we finally have this working.  We have a connection as well as data transfer.  One quick question which I think I know the answer to.  The device is attempting to communicate with a server that is located outside of the US.  Will your network allow that?