GSM SIM unable to register on network

  • 2
  • Problem
  • Updated 2 years ago
I'm unable to register my Aeris GSM SIM (IMSI: 204043396723135). I'm attempting to connect in Nome, AK which appears well-covered on the map, and has known GSM data connectivity (on the network provided by GCI).

I'm currently trying the SIM in an unlocked Galaxy S5 phone, which I have confirmed to have GSM 1900 Edge connectivity with a different SIM.

I have also tried the Aeris SIM in a SIM800c module with AT commands, and it appears that registration on the network is "forbidden" (AT+COPS code 3).

Any help would be greatly appreciated!
Photo of Eric Tweet

Eric Tweet

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Abraham Fuentes

Abraham Fuentes, Official Rep

  • 92 Posts
  • 0 Reply Likes
Hello Eric,

In an effort to get us to a common ground please confirm you have reviewed information found in the "Get Started ("; section of our online documentation.
It is clear you have successfully accomplished at least the first few steps which include assigning and provisioning the SIM on your account.

Beyond this, the next steps generally are as follows, Please validate that all the steps below have been taken:

1. Ensure the SIM is inserted into the device correctly
2. Ensure that your device is correctly configured and authorized, i.e. not SIM-locked, verify that the APN has been correctly set up in the device. APN:
3. Ensure that the device is powered on and it is not in radio-off mode, e.g. airplane or sleep mode
4. Ensure that the device is in coverage; Check the coverage map
5. After completing the above steps, please power-cycle the device.
6. If SIM does not communicate please provide us with time stamp of reset so that we can check our network logs.

Abraham Fuentes
Neo Support
Photo of Eric Tweet

Eric Tweet

  • 2 Posts
  • 0 Reply Likes
Hi Abraham,

Thank you for your reply.

Please take another glance at my initial inquiry. You'll find that nearly everything you noted has already been addressed there. I'll re-iterate here, for the sake of continuity and elaboration...

Yes, I've gone through the Get Started information.

1. It is inserted correctly. Again, I've replaced the aeris sim with other sims which function properly to verify this.
2. I have double-checked the device(s), and APN settings (again, by using other SIM cards and corresponding APNs in my various test devices, which all work well). The problem is Registering on the network - I haven't even gotten to the point where the APN configuration comes into play...
3. This step is irrelevant based on all of the other information I've given. The radio is blazing, and other SIM cards verify this.
4. I have already addressed this. The Coverage map shows I should be well-covered, and I've mentioned that I get GSM coverage using other SIM cards.
5. I have power cycled countless times, with various SIM cards. The aeris GSM is the only one that does not get past the network registration step.
6. My guess is that your network logs should not show anything, since I have never been able to get this aeris GSM sim to register on the partner networks. This means it would never have gotten the chance to "phone home" and show any data on your network logs. (that's an assumption, though I'm not a network engineer). However, check around 2018-01-11 22:19:33. That is when I simultaneously registered on the network using my Aeris LTE SIM, while attempting to also register using the GSM card. (NOTE: This was done in a dual-SIM GSM-only phone, which supports Quad-Band GSM).

Additional information:
- I have an Aeris LTE SIM which I've confirmed to work just fine on various devices (INCLUDING in a GSM quad band device, interestingly enough). So I'm familiar with the process of getting a SIM up and running.
- I cannot get the Aeris GSM SIM to work in any device. The problem is at the Network Registration stage, so this is before even reaching the data connectivity step.
- There are a total of two networks which show up in the list on my devices. I have tried all of the above with both of them. For the alternative SIMs I have, I've successfully connected to one network or the other, so I know that I have the ability to choose the network. Still the aeris GSM SIM fails to register on either network.
- When the SIM fails to register, I am still given the option for "Emergency Call" service (of course, I have not tried to see if that functionality works).

Please let me know if you need any other info, and thank you again for your reply.