No data connection on unlocked android device

  • 1
  • Problem
  • Updated 3 years ago
I received a set of SIM cards today, provisioned one, and am trying to test it out on an unlocked GSM phone.  I have set the APN to neo.iot.net.  (I'm assuming the "name" field is arbitrary and the "APN" field should be neo.iot.net).  I have allowed data and roaming data on the device.  I show signal in the form of "bars" with an "R" next to them (presumably for roaming).

I have been able to send a text to the device from the diagnostics page, and from the device to another device.

But, I cannot seem to establish a data connection.  

When I click "ping device" from the diagnostics page, I get:

8:35:04 PM$ ping 89185015032500238208
Device not in data session

Data Session says "never established data session".

Running out of ideas.
Photo of R Anderson

R Anderson

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Vaibhav Mareddy

Vaibhav Mareddy, Official Rep

  • 24 Posts
  • 0 Reply Likes
I see that device initially tried to get on AT&T, then hopped on to T-mobile, currently device is all registered but is not initiating any data. Did you try browsing some traffic, what device is it?
Do you see any data icon with G or E or 3G ?
Photo of R Anderson

R Anderson

  • 4 Posts
  • 0 Reply Likes
The device is an HTC G2 phone.  Where I would normally see an indication of G, E, or 3G, I only see "R".  As for browsing traffic, I'm not exactly sure how to go about that.
Photo of R Anderson

R Anderson

  • 4 Posts
  • 0 Reply Likes
Different behavior today for some reason.  I saw a 3G connection, then received a bunch of data on the phone (facebook message updates).  I quickly put it into airplane mode to prevent excessive data transfer.  Any idea what might have changed?
Photo of Vaibhav Mareddy

Vaibhav Mareddy, Official Rep

  • 24 Posts
  • 0 Reply Likes
Nothing changed on our side, did you try data mode on/ off?