No DNS

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Hi,

I made quite a bit of progress in fairly short order. It looks like my ppp connection is up and running and can see ppp0 with an assigned IP address when I invoke ifconfig. I even seem to have gotten DNS servers:

Dec 22 01:01:09 pppd[15018]: rcvd [IPCP ConfReq id=0x2 <addr 10.136.142.205>]
Dec 22 01:01:09 payrange_gg pppd[15018]: sent [IPCP ConfAck id=0x2 <addr 10.136.142.205>]
Dec 22 01:01:09 pppd[15018]: rcvd [IPCP ConfNak id=0x2 <addr 10.136.142.205> <ms-dns1 10.85.202.20> <ms-dns2 10.85.202.21>]
Dec 22 01:01:09 pppd[15018]: sent [IPCP ConfReq id=0x3 <addr 10.136.142.205> <ms-dns1 10.85.202.20> <ms-dns2 10.85.202.21>]
Dec 22 01:01:09 pppd[15018]: rcvd [IPCP ConfAck id=0x3 <addr 10.136.142.205> <ms-dns1 10.85.202.20> <ms-dns2 10.85.202.21>]
Dec 22 01:01:09 pppd[15018]: local  IP address 10.136.142.205
Dec 22 01:01:09 pppd[15018]: remote IP address 10.136.142.205
Dec 22 01:01:09 pppd[15018]: primary   DNS address 10.85.202.20
Dec 22 01:01:09 pppd[15018]: secondary DNS address 10.85.202.21
Dec 22 01:01:09 pppd[15018]: Script /etc/ppp/ip-up started (pid 15026)
Dec 22 01:01:10 pppd[14990]: Device ttyUSB1 is locked by pid 15018
Dec 22 01:01:10 pppd[15018]: Script /etc/ppp/ip-up finished (pid 15026), status = 0x0
Dec 22 01:01:11 ntpd[650]: Listen normally on 8 ppp0 10.136.142.205 UDP 123
Dec 22 01:01:11 ntpd[650]: peers refreshed



So... 

Why can't I ping www.google.com?  

I get:

ping: unknown host www.google.com

Regards,
Jeffrey Hall
Photo of Jeffrey Hall

Jeffrey Hall

  • 3 Posts
  • 0 Reply Likes
  • Like I'm pretty close to having this work!

Posted 2 years ago

  • 1
Photo of Norma Pavao

Norma Pavao, Official Rep

  • 126 Posts
  • 2 Reply Likes
Hi,

Can you provide the SIM ICCID or MSISDN?

Thank you,
The Neo Team
Photo of Jeffrey Hall

Jeffrey Hall

  • 3 Posts
  • 0 Reply Likes
Hi Norma,
Thanks for the prompt reply! :)

SIM card # is:
89185000150911120737

Regards,
-Jeff-
Photo of Norma Pavao

Norma Pavao, Official Rep

  • 126 Posts
  • 2 Reply Likes
Hi Jeff,

I was able to check DNS resolution against the 2 specified DNS servers and was able to resolve www.google.com:

/export/home/scp 102 > nslookup
Default Server:  nis003m.aeris.net
Address:  10.0.30.93

> server 10.85.202.20
Default Server:  uk-dns250.aeris.net
Address:  10.85.202.20

> www.google.com
Server:  uk-dns250.aeris.net
Address:  10.85.202.20

Non-authoritative answer:
Name:    www.google.com
Address:  216.58.204.4

> server 10.85.202.21
Default Server:  [10.85.202.21]
Address:  10.85.202.21

> www.google.com
Server:  [10.85.202.21]
Address:  10.85.202.21

Non-authoritative answer:
Name:    www.google.com
Address:  216.58.208.164

As a test do you have the ability to set a different dns server i.e. 4.2.2.2?

Regards,
The Neo Team
Photo of Jeffrey Hall

Jeffrey Hall

  • 3 Posts
  • 0 Reply Likes
Official Response
Ok, I got a clue. My routing table had no entries! For some reason, when the ppp interface came up no default route was added. I manually added a default route for the ppp interface and everything started working! What still puzzles me is that I have the defaultroute set in /etc/ppp/options. I thought that should handle adding a default route.
Photo of Norma Pavao

Norma Pavao, Official Rep

  • 126 Posts
  • 2 Reply Likes
Glad to hear it Jeff, appreciate the update.

Regards,
The Neo Team