ppp connections intermittent and poor connectivity at best

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Hello,

I'm trying to establish a PPP connection from a Raspberry Pi.  I'm using  a SIM800 modem and am able to get dialed into aeris fairly reliably, but when I try to establish the PPP session things are giving me a lot of problems.  

Looking at the debug logs on PPPD it looks like PAP authentication succeeds every time, but then there is a lot of back-and-forth and often eventual failure with an error of 'Protocol-Reject for Compression Control Protocol'.

Often times the session disconnects immediately after this message, but if I let it try 5-10 times sometimes it connects and gives me an IP address.  When it does my IP connectivity seems very slow with intermittent connectivity.  

Getting down into these Linux PPP configuration files has me out of my depth, can anyone help me troubleshoot what I'm doing wrong here?

Jim
Photo of Jim

Jim

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Jim,

Thanks for the question. In the past, and in a different context, we have observed a similar issue establishing PPP sessions for devices using Linux PPPD drivers. When Linux PPPD is used with Address Control Compression and Protocol Field Compression disabled (including the noaccomp and nopcomp options respectively) the Linux driver attempts MIP registration a second time after the first registration is successful. 

We have two recommended workarounds. If neither works for you please let us know and we'll do some further research.


1. In order to avoid the double MIP registration and subsequent failure the application should NOT include the following two options when establishing a PPP tunnel:
  •      noaccomp
  •      nopcomp

2. The following CHAT script can be used to check if you get a reliable connection. Also, please validate that you're using the correct APN. For the APN please refer to this tutorial.

CHAT script:
SAY "GSM chat\n"ECHO OFF
ABORT 'NO DIAL TONE'
ABORT 'NO DIALTONE'
ABORT 'NO ANSWER'
ABORT 'NO CARRIER'
ABORT 'DELAYED'
ABORT 'VOICE'
ABORT 'BUSY'
'' 'AT'
OK 'ATZ'
OK 'AT+CSQ'
# ----------------------------------
# Set the APN for your provider here
# ----------------------------------
#OK 'AT+CGDCONT=1,"IP","proxy"'
#OK 'AT+CGDCONT=1,"IP","aer.aerisapn.net"'
#OK 'AT+CGDCONT=1,"IP","neo.iot.net"'
OK 'AT+CGDCONT=1,"IP","internet"'
SAY "Dialing...\n"
#OK 'ATD*99#'
OK 'ATD*99***1#'
SAY "Waiting for CONNECT...\n"
TIMEOUT 120
CONNECT ''
SAY "Connected\n"


Regards,
Bob 
Photo of Jim

Jim

  • 2 Posts
  • 0 Reply Likes
Bob,

Thank you for responding to my message.  I'm somewhat embarrassed to say that I figured out my problem... my antenna was defective.  After countless hours digging around in Linux log files and trying various configuration combinations, I finally realized that AT+CSQ was returning low values, so I plugged a new antenna on my modem and PPPD started connecting almost instantly.  Problem solved.  

Jim
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Awesome Jim! Glad you got it resolved. And thanks for letting us know.

Regards,
Bob