SMS failed. Cause: AerFrame ErrorCode 6

  • 2
  • Problem
  • Updated 1 year ago
Trying to send an SMS from the Neo Web Portal, but receiving ErrorCode 6.

9:22:16 AM$ sendsms 89185015032500233373 '+XT:1002,,,neo.iot.net'
Send MT-SMS accepted. Operation in progress
Send MT-SMS failed. Cause: AerFrame ErrorCode 6

Is this a network issue or a problem with my SIM?
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Jesse Hamus

Jesse Hamus, Official Rep

  • 24 Posts
  • 0 Reply Likes
Thanks for posting your issue.  Please have the device powered down and powered back up to aide in troubleshooting.  Additionally, the device register has been reset.  Once power is returned, please attempt to resend SMS and report the results.
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes
The device was powered down, and reset.  I have issued the SMS command again, and it resulted in the same error:

5:35:01 PM$ sendsms 89185015032500233373 '+XT:1002,,,neo.iot.net'
Send MT-SMS accepted. Operation in progress
Send MT-SMS failed. Cause: AerFrame ErrorCode 6
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes
Anyone else having an issue sending SMS?  Also, I noticed on the Diagnostics page that it says the following:

Network Status:  network is up
Provisioning: Data - Allowed & SMS - Allowed
Registration:  blank
Data Session: blank

Any thoughts?
Photo of Norma Pavao

Norma Pavao, Official Rep

  • 128 Posts
  • 2 Reply Likes
Hi Thomas,

By reviewing the logs your SIM is not actively registered which is why SMS is failing.  Your device needs to maintain cellular registration in order for SMS to function. I have issued a clear registration on the device, the device should try to re-initiate a connection.

Another observation the device logs show the device is moving between switches, is this a stationary device or is it a moving device?

Regards,
The Neo Team
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes
The device has been in my vehicle throughout the day, so that would explain it moving between switches....

At the moment, I just powered on the device, and it is in a stationary location.  I will give it 15-20 min and check the status via the portal again..

Thanks for looking into this,
Tommy
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes
Now I am getting ErrorCode 5...

Send MT-SMS failed. Cause: AerFrame ErrorCode 5
Photo of Norma Pavao

Norma Pavao, Official Rep

  • 128 Posts
  • 2 Reply Likes
Hi Thomas,

I checked the logs and see the failures the device is not registering on the network.  Do you have signal strength, have you attempted to place the SIM in a different device?  Being that the network is not seeing activity from the device to register that is the cause of the error.

Regards,
The Neo Team
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes
Thank you for looking into this.  Strange.  I am showing signal strength, and it is behaving as if it is connected.  I will put a SIM from another carrier in and see if I can communicate with the device.  Once comms are established, Ill bring it back to the Neo network.

Thank you for your help...

Tommy
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes
Strange.  I put in an ATT Sim, and the device works just fine.  In your logs, do you see any communication between my device and your system for the previous 48hrs?  Could it be a coverage issue?  According to your coverage map, I should have service here.  Are your coverage maps current?

Thanks,
Tommy
Photo of Jesse Hamus

Jesse Hamus, Official Rep

  • 24 Posts
  • 0 Reply Likes
Our logs show the device is communicating with our network from the time period December 14th up until current timeframe, December 19th, 20:45:22 GMT.  The device is registered with the cellular network as recent as 2016-12-18 23:28:39 GMT.  Today, the device was able to SMS MT successfully at 2016-12-19 20:45:22 thru the Neo web portal:

2:45:12 PM$ sendsms 89185015032500233373 'test'
Send MT-SMS accepted. Operation in progress
Send MT-SMS in progress
Send MT-SMS in progress
Send MT-SMS processed successfully

Coverage maps posted on our portal should be up to date.

Regards,

Neo Team
Photo of Ryan

Ryan

  • 16 Posts
  • 0 Reply Likes
Hi Jesse

I am having the same issue with:
89185000160627260990

This is a 3g device using your micro sim.

Please advise
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes
Thank you for checking this.  I drove into town to check my cellular connectivity, and it looks like I no longer have Neo coverage at my home.  Normally I do have coverage, and your coverage map does show me covered.  Could the ATT 2g sunset be having an effect on coverage areas?  

Either way, your system is performing correctly, and it appears this error was due to lack of coverage when I was testing.  I didtn even think of checking because I have had coverage for the past year or so no problem...

Tommy
Photo of Thomas Remmert

Thomas Remmert

  • 11 Posts
  • 0 Reply Likes
I am still experiencing coverage issues in my area.  If I check your 2g coverage map, I should be well within your coverage area.  I can also drive 10-15 miles, and still not receive coverage.   BUT, here is the strange thing.  I few of my 2g devices are working just fine at my home, but none of my "new" 2g devices will connect.  

Is it possible that your new SIM cards do not work with the 2g network?