ZTE MF206A Issue

  • 1
  • Question
  • Updated 2 years ago
I'm using the Neo SIM card with the ZTE MF206A cellular module. On startup of the ZTE module's software application, the status never passes "Device is initializing" and restarts. When I use AT commands to send a SMS message, there isn't an error but the SMS messages are never actually sent. I've been able to use the module with an AT&T SIM card. The ZTE module is unlocked and can be used with any carrier.

I'm hoping someone can help me troubleshoot this.
Photo of Martin Hristov

Martin Hristov

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Abraham Fuentes

Abraham Fuentes, Official Rep

  • 55 Posts
  • 0 Reply Likes
Martin,

Thank you for bringing this problem to our attention.
The received response typically indicates the device may not be properly configured within our network. We are investigating further in an attempt to resolve your issue.
However in the meantime please confirm the device in question is ICCID: 89185000150911601090.

Thanks
Abraham Fuentes
Photo of Martin Hristov

Martin Hristov

  • 5 Posts
  • 0 Reply Likes
Abraham,

Yes, that is the ICCID.

Martin
Photo of Abraham Fuentes

Abraham Fuentes, Official Rep

  • 55 Posts
  • 0 Reply Likes
Martin,
Our back end issue should be resolved. Can you power cycle/reset device and let us know if problem remains? Also please provide us reset time stamp.
Thanks
Photo of Martin Hristov

Martin Hristov

  • 5 Posts
  • 0 Reply Likes
Abraham,

The problem persists. The reset time was approximately 11:30 on 6/1.

Martin
Photo of Martin Hristov

Martin Hristov

  • 5 Posts
  • 0 Reply Likes
I recently tested the SIM card with my personal phone which was unlocked. The behavior is the same as with the ZTE module, SMS messages can be sent through Android without error but they are never actually received by recipients.
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Martin,

Thanks for the post. I've been chatting with Abraham about this and have a couple questions. So I'm sure I understand the issue please tell me exactly what you're attempting. For example....

You're sending SMS-MO from your device, and in one case from your mobile phone. Correct?
When you send from the device you're using an AT command. Correct?
What is the intended recipient of you SMS-MO from the device with your Neo SIM?

Is there anything else I'm missing or have misunderstood?

Regards,
Bob
Photo of Martin Hristov

Martin Hristov

  • 5 Posts
  • 0 Reply Likes
1. Correct.
2. Correct.
3. I'm sending a test SMS message from my ZTE module with Neo SIM to my personal phone number.
Photo of Bob Heckmann

Bob Heckmann, Official Rep

  • 349 Posts
  • 12 Reply Likes
Hi Martin,

Thanks for the reply. As a network security feature Neo doesn’t support SMS with devices which are not connected to the Aeris network. This protects your connected devices from potentially harmful network behavior from external sources.

You can learn how to use our API to transmit SMS with the tutorial on this page.


Regards,
Bob